Problém s IC2 serverem

Zdravím, poslední dobou mám problém s IC2 serverem. Na server se sice připojím, ale při načítání okolních bloků se po pár vteřinách sekne. Zkoušel jsem, jestli není náhodou problém na mé straně, takže jsem si udělal čistou instalaci, ale bohužel beze změny.

Takže moje teorie je, že to způsobuje nějaký blok/ entita, co jsem naposledy vyrobil nebo použil.
Naposledy jsem se tam zabýval šlechtěním včel, udělal jsem si velký úl (Alveary) s Imperiálkama a ještě jsem si vyrobil malou linku na výrobu cihel (cobble -> písek -> hlína -> clay).

Možná by se dalo něco zjistit z logu serveru, co to způsobuje, ale kdyby náhodou ne a nešlo by to nějak jednoduše vyřešit, tak jsem klidně pro odstranit část pozemku, klidně i celý kdyby to jinak nešlo.

Galerie jak to vypadá po připojení:

Komentáře

  • Novejsi forge jsi zkousel?
  • Zkoušel jsem tak ňák všechno, jak nejnovější forge, tak i starší. Javu používám tu nejaktuálnější a co se týče Optifine, tak ten jsem si taky na zkoušku vyhodil. Nic nepomohlo.
  • Na serveru jsem si vcera vsiml, ze mu neco vyzralo veskerou pamet. To se driv nedelo, zjevne to bude mit nejakou souvislost. Delsi dobu jsem neaktualizoval modpack, mozna uz nadesel cas :) Stale ale cekam na opravu jednoho zasadniho bugu v refined storage, ale autor se k tomu moc nema.
  • Aktualizace by byla dobrá, zrovna nedávno když jsem se snažil rozjet Eden, jsem projížděl i všechny IC módy a u některých vydali těch aktualizací už hafo. Nejvíc se mi ale líbila jedna drobná úprava z Quarku a to, že guardiani se spawnují už jenom v hlubokém oceánu. Mám domek blízko moře, takže jsem s nimi měl dost problém, až jsem kvůli tomu musel zasypat část moře, ale taky kvůli spoustě dropnutého inkoustu z olihní. Má docela velký vliv na fpska.
  • HunterzHunterz [Admin]
    upraveno 8. March 2018
    Porad cekam na aktualizaci refined storage, kdyz koukam do jeho issues, hromadi se tam bugy souvisejici s autocraftingem a spotrebou pameti. Autor sice do gitu neco commituje, ale ty zasadni bugy se mu stale opravit nepodarilo.
  • Jaj tak nakonec v noci bylo RS aktualizovano po dlouhe dobe. Dokonce byl opraven i jeden z tech horsich bugu. O vikendu budem aktualizovat :)
    Adam4CZman_or_lady
  • Tak bohužel i po aktualizaci problém přetrval, tentokrát se to seklo už po načtení 2 chunků a dokonce mi to vyhodilo i crash log. Snad v něm bude něco užitečného, moc se v tom nevyznám.
  • HunterzHunterz [Admin]
    upraveno 11. March 2018
    podle myho to delaji ty item framy, crash je primo z renderu minecraftu, zredukuj pocet itemframu ve svem okoli
  • Tak zkusit se to může, ale já s tím bohužel nic neudělám, když se server sekne po 2 vteřinách. Takže by to šlo nejspíš vyřešit pouze přes MCEdit, nebo jiný editor a všechny framy v okolí odstranit.
  • Az nahodim lobby vecer, zkus jeste stahnout view distance na uplne minimum a pak ty item framy (ty sklenene z quarku) po jednom vymlatit. Kdyby to neslo, muzu to zkusit pak nejak pomoci pluginu, souradnice v tom crashlogu jsou.
  • Stáhnutí dohledu nemělo téměř žádný vliv, sice mi to tentokrát nespadlo, ale server i tak zamrzl. Pak jsem ještě zkusil ho vrátit na původních 13 a v pohodě, takže možná to s těma rámy byl jen ojedinělý případ. Tentokrát mě to odtamtud ani nevykoplo, ale i tak je problém pořád stejný. Nejde nic položit, zničit ani použít a opětovné připojení není možné "Exception Connecting:ReadTimeoutException : null".
  • Zda se, ze se ti podarilo postavit neco, co zpusobi vyzrani pameti, server prestane odpovidat.
  • Bude to chtit nejakou soucinnost, nez se pripojis na server prijd na teamspeak, zapnu pak nejaky debug, at zjistime co tam vyzira tu pamet. Predpokladam, ze to bude refined storage bug: https://github.com/raoulvdberge/refinedstorage/issues/1698
    tykajici se autocrafteru. To je vubec nejzabugovanejsi stroj z celeho Refined Storage podle tech nahlasenych bugu.
  • Zkus se tedy pripojit s nejnizsi render distance a pokud to pujde okamzite vypni/smaz recept v autocrafteru, pripadne ten autocrafter uplne zbourej pokud to pujde. Chce to udelat co nejrychleji po pripojeni nez to zas vyzere pamet.
  • Autocrafterem to není, žádný totiž nemám. Je ale možný, že to způsobuje refined, protože při každém připojení se chunk v kterém mám jeho základnu (controller, crafting grid, disk drive, solderer a wireless transmitter) nenačte. Stejně tak tam mám i pár strojů z Immersivu a Mekanismu. Pro představu jak to tam vypadá přikládám galerii.

    https://imgur.com/a/GDaUs
  • HunterzHunterz [Admin]
    upraveno 13. March 2018
    Aha, takze ty refined stroje asi ani nepodari vypnout/demontovat ?

  • Těžko... leda že by se ti nějak podařilo mě portnout přímo před stroj, protože teďkon jsem před barákem u včel. Je to otázka doslova pár vteřin než se to sekne. Jinak jsem pořád toho názoru, že můžeš klidně odstranit část pozemku, možná by se tak ten problém i snáz našel, když by se vědělo kterej chunk je vadnej.
  • zkusim se tam vecer k tobe podivat primo
  • Hm tak to vypada na bugnuty chunk.
  • HunterzHunterz [Admin]
    upraveno 14. March 2018
    Pustil jsem opravator, a ten bugnuty chunk smazal. Vyzkousej se pripojit a dej vedet. Bohuzel nemam tak starou zalohu abych dokazal obnovit konkretni chunk z doby kdy fungoval. Navic by to bylo asi komplikovane. Takhle jen ten nastroj smazal vadny chunk a udelal regen daneho chunku. Vetsina tvych staveb zustala nedotcena. Pravdepodobne to ale odnesl storage, ale to uz uvidis sam.
  • Vyzkoušeno a vše se zdá být v pořádku. Jinak to odnesl celý storage, bio-generátory, skleníky z immersivu a pár beden. Ale tak hlavně že už vše funguje jak má, ty ztracený předměty mě vůbec netrápěj. Novej regen mi alespoň dává příležitost udělat věci jinak, takže díky za vyřešení :)
    Adam4CZHunterz
Tato diskuze je zavřená.